Bilder werden nicht in der Mediathek angezeigt

Ich setze gerade eine WordPress Seite einer Kundin neu auf. Ein Directory Theme (Javo) mit einer Multisite Installation und dazu noch WPML mit neun oder zehn Sprachen. Das Ganze läuft seit 2014 und lässt sich auch nicht mehr richtig Updaten, danach ist immer was verbogen. Außerdem war schon der eine oder andere Admin oder so ähnlich dran, es ist wie eine Sockenschublade mit vielen schwarzen sich ähnelnden Socken, die nicht zusammenpassen wollen. Die Seite lässt sich aber auch nicht einfach einpacken und neuaufbauen und zu allem Überfluss gibt es auch noch korrupte Dateien, da war wohl auch mal ein Hacker am Werk. Ich hab einiges probiert, sogar Duplicator Pro, ich bin jetzt am Handneuaufbau, bei dem dann auch gleich das Theme gewechselt werden soll. Unter anderem deswegen, weil sich auf der alten Seite auch nicht wirklich ein effektives Caching einsetzen lässt, ein Staging sowieso nicht klappt und … es gibt viele Gründe …

Dank der Import-Export-Funktion und mit ein wenig Regex etc. ist das aber alles eigentlich kein Problem. Die Bilder nehme ich mit der WordPress Import Export Funktion mit rein, ich bin darauf angewiesen, dass die Bilder ihre Nummern behalten.

Bilder werden nach dem Import nicht in der WordPress Mediathek angezeigt

Leider werden die Bilder aber nach dem Import nicht in der Mediathek angezeigt. Eigentlich nicht schlimm, es sind die alten Bilder, die sind schon verwendet, eher unwahrscheinlich, dass die noch mal zum Einsatz kommen. Aber es nervt, es ist nicht perfekt. Also habe ich mich auf die Suche nach dem Problem begeben. Alle vorgeschlagenen Problemlösungen (darunter auch Rechte der Bilder und Ordner verändern, gucken, ob die Bilder den richtigen Besitzer haben) hat nichts gebracht.

Problem Sprachauswahl verwirrt wohl die Zuordnung in der Mediathek

Das Problem war die WPML Installation. Da Bilder importieren relativ langweilig ist, mach ich das immer so am Ende der Schicht. Während neuaufsetzen, denken, konfigurieren mache ich lieber, wenn ich fertig bin. Sobald ich aber WPML installiert habe, geht bei den Bildern noch die Info mit, zu welcher Sprache sie gehören. Und in dem Moment findet sie die Mediathek nicht mehr. Die Lösung lautet also einfach: Erst Bilder importieren, dann WPML installieren und konfigurieren.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.